+关注
已关注

分类  

暂无分类

标签  

暂无标签

日期归档  

暂无数据

部署时出现“错误:无效要求:pip3 install torch == 1.5.0 + cpu torchvision == 0.6.0 + cpu -f”

发布于2021-05-01 01:25     阅读(1028)     评论(0)     点赞(28)     收藏(2)


0

1

2

3

4

5

6

我在Heroku上部署了一个应用程序,并且该应用程序需要在服务器上安装Torch模块,并且由于此错误,我无法使用git推送应用程序...。我尝试了很多方法,但无法推送...告诉我我应该在requirements.txt中写什么才能安装割炬


解决方案


您需要编写与文件中所需版本相对应的torch(和torchvision,如果需要)的wheel文件的URL(来自torch_stable.htmlrequirements.txt然后,pip将安装wheel文件。

例如

https://download.pytorch.org/whl/cpu/torch-1.5.0%2Bcpu-cp37-cp37m-linux_x86_64.whl

上面的文件对应于pytorch(cpu)1.5,python 3.7,linux。

0

1

2

3

4

5

6



所属网站分类: 技术文章 > 问答

作者:黑洞官方问答小能手

链接: https://www.pythonheidong.com/blog/article/960776/e226c2a327e3723fe14e/

来源: python黑洞网

任何形式的转载都请注明出处,如有侵权 一经发现 必将追究其法律责任

28 0
收藏该文
已收藏

评论内容:(最多支持255个字符)